Yardım Formülü Koda Çevirme

karaca11

Yeni Üye
Katılım
6 Nis 2019
Mesajlar
3
En İyi Yanıtlar
0
Beğeniler
0
Puanları
1
Yaş
48
Konum
Zonguldak
Ad Soyad
Hüseyin KARACA
#1
Merhaba Arkadaşlar; İş Sağlığı ve Güvenliği ile ilgili olarak eğitim süreleri konulu bir tablo oluşturuyorum. Basit formülleri tamamladım, ancak karmaşık bir formülü koda çevirirken zorlandım. Yardımlarınızı bekliyorum.
=EĞER(A2<10;"YOK";EĞER(A2<50;A2*10;EĞER(A2<250;A2*15;EĞER(249<A2;A2*20))))
Böyle bir formül mevcut. "A2" alanı manuel girilen, çalışan personel sayısı.
 

Admin

Yönetici
Site Yöneticisi
Katılım
25 May 2018
Mesajlar
1,054
En İyi Yanıtlar
77
Beğeniler
855
Puanları
113
Konum
İstanbul
#2
Sonucu A1'e yazacak şekilde, bu kodları kullanabilirsiniz. İncelerseniz mantığı anlarsınız. (y)

VBA:
    Select Case Range("A2")
        Case Is < 10
            Range("A1") = "YOK"
        Case Is < 50
            Range("A1") = Range("A2").Value * 10
        Case Is < 250
            Range("A1") = Range("A2").Value * 15
        Case Else
            Range("A1") = Range("A2").Value * 20
    End Select
 

karaca11

Yeni Üye
Katılım
6 Nis 2019
Mesajlar
3
En İyi Yanıtlar
0
Beğeniler
0
Puanları
1
Yaş
48
Konum
Zonguldak
Ad Soyad
Hüseyin KARACA
#3
Merhaba; Yardımlarınız için teşekkür ediyorum; Verdiğiniz değerleri girdim, ancak sorgulama çalışmadı maalesef; Dediğiniz gibi A1 gelen yere sonucu girdim, şöyle ki;

Select Case Range("fieldname2")
Case Is < 10
Range("fieldname52") = "YOK"
Case Is < 50
Range("fieldname52") = Range("fieldname2").Value * 10
Case Is < 250
Range("fieldname52") = Range("fieldname2").Value * 15
Case Else
Range("fieldname52") = Range("fieldname2").Value * 20
End Select

ancak sonucu alamadım.
 

Admin

Yönetici
Site Yöneticisi
Katılım
25 May 2018
Mesajlar
1,054
En İyi Yanıtlar
77
Beğeniler
855
Puanları
113
Konum
İstanbul
#4
Dosyanızı ekleyin lütfen.
 

karaca11

Yeni Üye
Katılım
6 Nis 2019
Mesajlar
3
En İyi Yanıtlar
0
Beğeniler
0
Puanları
1
Yaş
48
Konum
Zonguldak
Ad Soyad
Hüseyin KARACA
#5
Merhaba; Herhangi bir dosya yok. "Calculated Fields Form" World Press eklentisi içerisinde Diğer Sağlık Personeli için vermiş olduğunuz formülü yazdığımda sonuç boş geliyor.

aşağıdaki linkten giriş yapıp ilgili eklentiden inceleyebilirsiniz; Yardımlarınız için şimdiden teşekkürler

Giriş – İstanbul Vizyon iş güvenliği

Kullanıcı Adı:
H_AKAY
Hk123333.
 

Admin

Yönetici
Site Yöneticisi
Katılım
25 May 2018
Mesajlar
1,054
En İyi Yanıtlar
77
Beğeniler
855
Puanları
113
Konum
İstanbul
#6
O eklenti ile ilgili bilgim yok.
Verilen kodlar vba tarafında kullanılabilir.
 
Üst Alt