Yardım Formülü Koda Çevirme

karaca11

Yeni Üye
Katılım
6 Nis 2019
Mesajlar
3
Puanları
1
Yaş
48
Konum
Zonguldak
Ad Soyad
Hüseyin KARACA
Merhaba Arkadaşlar; İş Sağlığı ve Güvenliği ile ilgili olarak eğitim süreleri konulu bir tablo oluşturuyorum. Basit formülleri tamamladım, ancak karmaşık bir formülü koda çevirirken zorlandım. Yardımlarınızı bekliyorum.
=EĞER(A2<10;"YOK";EĞER(A2<50;A2*10;EĞER(A2<250;A2*15;EĞER(249<A2;A2*20))))
Böyle bir formül mevcut. "A2" alanı manuel girilen, çalışan personel sayısı.
 

Admin

Yönetici
Site Yöneticisi
Katılım
25 May 2018
Mesajlar
1,097
Puanları
113
Konum
İstanbul
Web sitesi
www.excelarsivi.com
Ad Soyad
Excel Arşivi
Sonucu A1'e yazacak şekilde, bu kodları kullanabilirsiniz. İncelerseniz mantığı anlarsınız. (y)

PHP:
    Select Case Range("A2")
        Case Is < 10
            Range("A1") = "YOK"
        Case Is < 50
            Range("A1") = Range("A2").Value * 10
        Case Is < 250
            Range("A1") = Range("A2").Value * 15
        Case Else
            Range("A1") = Range("A2").Value * 20
    End Select
 

karaca11

Yeni Üye
Katılım
6 Nis 2019
Mesajlar
3
Puanları
1
Yaş
48
Konum
Zonguldak
Ad Soyad
Hüseyin KARACA
Merhaba; Yardımlarınız için teşekkür ediyorum; Verdiğiniz değerleri girdim, ancak sorgulama çalışmadı maalesef; Dediğiniz gibi A1 gelen yere sonucu girdim, şöyle ki;

Select Case Range("fieldname2")
Case Is < 10
Range("fieldname52") = "YOK"
Case Is < 50
Range("fieldname52") = Range("fieldname2").Value * 10
Case Is < 250
Range("fieldname52") = Range("fieldname2").Value * 15
Case Else
Range("fieldname52") = Range("fieldname2").Value * 20
End Select

ancak sonucu alamadım.
 

karaca11

Yeni Üye
Katılım
6 Nis 2019
Mesajlar
3
Puanları
1
Yaş
48
Konum
Zonguldak
Ad Soyad
Hüseyin KARACA
Merhaba; Herhangi bir dosya yok. "Calculated Fields Form" World Press eklentisi içerisinde Diğer Sağlık Personeli için vermiş olduğunuz formülü yazdığımda sonuç boş geliyor.

aşağıdaki linkten giriş yapıp ilgili eklentiden inceleyebilirsiniz; Yardımlarınız için şimdiden teşekkürler

Giriş – İstanbul Vizyon iş güvenliği

Kullanıcı Adı:
H_AKAY
Hk123333.
 
Üst Alt