Çözüldü Açılır Listeden Pivot Veri Getirmek

Durum
Üzgünüz bu konu cevaplar için kapatılmıştır...

myscandium

Yeni Üye
Katılım
18 Ara 2018
Mesajlar
3
Puanları
3
Yaş
31
Konum
İzmir
Ad Soyad
Feyyaz Özkan
Merhaba,

Ekli örnek dosyada F3 hücresindeki açılır listeden müşteri seçtiğimde tıpkı aşağıdaki pivot tabloda olduğu gibi aldığı ürün ve adetleri getirmesini sağlamak için yöntem arıyorum. Pivot tablo işimi görmüyor çünkü F3 hücresi farklı yerlerdeki formülleri etkiliyor, açılır liste olarak kalması şart. Pivot tablodaki filtre alanını =F3 yapabilsem sorunum yine çözülecek ancak orası değiştirilebilir alan değil biliyorsunuz ki.

Desteğinizi rica ediyorum.
 

Ekli dosyalar

Admin

Yönetici
Site Yöneticisi
Katılım
25 May 2018
Mesajlar
1,082
Puanları
113
Konum
İstanbul
Web sitesi
www.excelarsivi.com
Ad Soyad
Excel Arşivi
Bu Dizi Formülünü kullanabilirsiniz.
VBA:
=EĞERHATA(İNDİS(B$1:B$18;KÜÇÜK(EĞER($A$1:$A$18=$F$3;SATIR(B$1:B$18));SATIR()-2));"")
G3 hücresine bu formülü yapıştırıp o hücre içinde F2'ye basın sonra da sırasıyla CTRL + SHIFT + ENTER'a basın ve formülü sağa ve aşağıya doğru çekin.
 

myscandium

Yeni Üye
Katılım
18 Ara 2018
Mesajlar
3
Puanları
3
Yaş
31
Konum
İzmir
Ad Soyad
Feyyaz Özkan
Bu Dizi Formülünü kullanabilirsiniz.
VBA:
=EĞERHATA(İNDİS(B$1:B$18;KÜÇÜK(EĞER($A$1:$A$18=$F$3;SATIR(B$1:B$18));SATIR()-2));"")
G3 hücresine bu formülü yapıştırıp o hücre içinde F2'ye basın sonra da sırasıyla CTRL + SHIFT + ENTER'a basın ve formülü sağa ve aşağıya doğru çekin.
Çok çok teşekkürler. Tam olarak işimi gördü ve sayenizde pek çok alanda kullanabileceğim bir fonksiyon öğrenmiş oldum. Emeğinize sağlık.
 
Durum
Üzgünüz bu konu cevaplar için kapatılmıştır...
Üst Alt