Çözüldü Sütundaki Benzer Olmayan Verilerin Sayısını Bulma Hk.

Durum
Üzgünüz bu konu cevaplar için kapatılmıştır...

skaan

Yeni Üye
Katılım
14 Kas 2018
Mesajlar
14
En İyi Yanıtlar
0
Beğeniler
1
Puanları
3
Yaş
48
Konum
İstanbul
Ad Soyad
Süleyman Kaan Aksoy
#1
Merhaba;
Sütundaki sayılardan benzer olmayan verilerin sayısını bulmak istemekteyim. Sütünda alt alta bulunan veriler arasında tek olanlar cift olanlar hatta ikiden fazla aynı olan sayılar bulunmakta. Bu sayıları aynı olanları bir tane olarak saymak istemekteyim. Örnek dosyamda şirket sutununu filtrelediğimde bana benzersiz olan verlerin sayısını vermeli..Örneğin sütunda;
1000 şirketinde 1 tane 8400000076 ( benzersiz )
1000 şirketinde 1 tane 8400000200 ( benzersiz )

1100 şirketinde 1 tane 8400000259 ( benzersiz )
1100 şirketinde 1 tane 8400000344 ( benzersiz )
1100 şirketinde 1 tane 8400000500 ( benzersiz )

verisi bulunmakta.. Bunları sütunda şirket filtrelemesi yaptığımda formül ile saydığımda bana şirkete göre benzersiz verilerin toplamı vermeli. ( 1000 Şirketi 2 tane - 1100 şirketi 3 tane )Toplam 5 tane

Örnek dosyam ektedir..
Yardımcı olmanızı rica ediyorum
 

Ekli dosyalar

Admin

Yönetici
Site Sahibi
Katılım
25 May 2018
Mesajlar
1,000
En İyi Yanıtlar
72
Beğeniler
773
Puanları
113
Konum
İstanbul
#2
Merhaba,
Bu formülü kullanabilirsiniz. (y)
VBA:
=TOPLA.ÇARPIM((D3:D14<>"")/EĞERSAY(D3:D14;D3:D14&""))
 

skaan

Yeni Üye
Katılım
14 Kas 2018
Mesajlar
14
En İyi Yanıtlar
0
Beğeniler
1
Puanları
3
Yaş
48
Konum
İstanbul
Ad Soyad
Süleyman Kaan Aksoy
#3
Merhaba;
Tablo da genel olarak formül yazıldığında doğru adetı verıyor. Ancak örneğin dosyadaki 1000 şirketini yada 1100 şirketini filtrelediğimde adet doğru gelmiyor. Bu sorunu nasıl çözebiliriz..
 

Admin

Yönetici
Site Sahibi
Katılım
25 May 2018
Mesajlar
1,000
En İyi Yanıtlar
72
Beğeniler
773
Puanları
113
Konum
İstanbul
#4
Örnek dosya göndererek çözümü hızlandırabilirsiniz. (y)
 

skaan

Yeni Üye
Katılım
14 Kas 2018
Mesajlar
14
En İyi Yanıtlar
0
Beğeniler
1
Puanları
3
Yaş
48
Konum
İstanbul
Ad Soyad
Süleyman Kaan Aksoy
#5
Merhaba örnek dosyam ektedir.. örneğin dosyadaki 1000 şirketini yada 1100 şirketini filtrelediğimde adet doğru gelmiyor.
 

Ekli dosyalar

skaan

Yeni Üye
Katılım
14 Kas 2018
Mesajlar
14
En İyi Yanıtlar
0
Beğeniler
1
Puanları
3
Yaş
48
Konum
İstanbul
Ad Soyad
Süleyman Kaan Aksoy
#6
Tekrar merhaba;
Konu hakkında yardımcı olabilecekmisiniz.. ?? Çözüm mevcutmudur ??

Saygılar
SKaaan
 

Admin

Yönetici
Site Sahibi
Katılım
25 May 2018
Mesajlar
1,000
En İyi Yanıtlar
72
Beğeniler
773
Puanları
113
Konum
İstanbul
#7
Makro ile hızlı bir çözüm sunabiliriz isterseniz.
 

skaan

Yeni Üye
Katılım
14 Kas 2018
Mesajlar
14
En İyi Yanıtlar
0
Beğeniler
1
Puanları
3
Yaş
48
Konum
İstanbul
Ad Soyad
Süleyman Kaan Aksoy
#8
Yardımcı olursanız çok sevinirim..Makro olabilir tabiki..
 

Admin

Yönetici
Site Sahibi
Katılım
25 May 2018
Mesajlar
1,000
En İyi Yanıtlar
72
Beğeniler
773
Puanları
113
Konum
İstanbul
#9
Her iki çözümü vereyim yine de.. :)

Formülle çözüm:
C1 hücresine bu formülü yapıştırıp Dizi Formülüne çevirin..
VBA:
=İNDİS(C3:C14;KAÇINCI(1;ALTTOPLAM(3;KAYDIR(C3;SATIR(1:13)-1;;));0))
D1 hücresine bu formülü yapıştırıp Dizi Formülüne çevirin..
VBA:
=TOPLA(EĞER($C$3:$C$14=$C$1;1/EĞERSAY($D$3:$D$14;$D$3:$D$14&"");0))
Makro ile çözüm:
VBA:
Sub Emre()
    Dim evn As Range, say%
    For Each evn In Range("D3:D100").SpecialCells(xlCellTypeVisible)
        If WorksheetFunction.CountIf(Range("D3:D" & evn.Row), evn.Value) = 1 Then
            say = say + 1
            Range("D1").Value = say
        End If
    Next evn
    say = Empty
End Sub
İyi akşamlar.. (y)
 
Son düzenleme:

skaan

Yeni Üye
Katılım
14 Kas 2018
Mesajlar
14
En İyi Yanıtlar
0
Beğeniler
1
Puanları
3
Yaş
48
Konum
İstanbul
Ad Soyad
Süleyman Kaan Aksoy
#10
Yardımlarınız için teşekkürler..
İyi yıllar dilerim.. (y)
 
Durum
Üzgünüz bu konu cevaplar için kapatılmıştır...
Üst Alt