Yardım Tarih formatına göre EĞERSAY

muzaffer.keskin

Yeni Üye
Katılım
3 Ağu 2019
Mesajlar
3
En iyi yanıt
0
Puanları
1
Yaş
43
Konum
İstanbul
Ad Soyad
Muzaffer Keskin
Merhaba,

SQL üzerinden aldığım rapor excelim var, bu excel tablosundaki "tarih" kolonu
1342

Bu şekilde gözüküyor, =EĞERSAY(A:A;"1.1.2019") yaptığımda sonuç "0" çıkıyor, şu yöntemle çözdüm "B" sütununa =METNEÇEVİR(A:A;"g.a.yyyy") formül yazdığımda bana olması gereken tarih formatını "1.4.2019" olarak veriyor "C" sütununa =EĞERSAY(B:B;"1.4.2019") yazdığımda sonucunu buluyorum.

Ama bu işlem uzun olduğundan hesaplama yaptırdığımı satır sayısı 7000 - 8000 üzerinde olabiliyor, tek formül de hem METNEÇEVİR işlemini hem de EĞERSAY nasıl yaptırırım.

Yardımınız için şimdiden teşekkürler.
 

muzaffer.keskin

Yeni Üye
Katılım
3 Ağu 2019
Mesajlar
3
En iyi yanıt
0
Puanları
1
Yaş
43
Konum
İstanbul
Ad Soyad
Muzaffer Keskin
Merhaba,

İlk önce ilginiz için teşekkürler.

Örnek dosyayı ekledim, 3 kolonda da tarih alanım var, amacım tek formül ile tarihe göre kişileri saydırmaktır.

İyi çalışmalar.
 

Ekli dosyalar

muzaffer.keskin

Yeni Üye
Katılım
3 Ağu 2019
Mesajlar
3
En iyi yanıt
0
Puanları
1
Yaş
43
Konum
İstanbul
Ad Soyad
Muzaffer Keskin
Merhaba,

Bu tabloların dışın da extra tablolarım daha var, örnek "aldığı çağrı sayısı", "mola süresi" gibi, bende şunu yapıyorum.

EVREN : MOLA SÜRESİ : 1:30:00 ALDIĞI ÇAĞRI : 34 gibi bunu tarihe bağlayarak yapıyorum.

ÇOKEĞERSAY(A1,"1.1.2019",B1,"EVREN",C1,"MOLA SÜRESİ") gibi

Bu formül bana 30 dakika belki daha fazla zaman kazandıracak

Teşekkürler.
 
Üst Alt