Yardım girilen tarihe göre verileri listeleme

alix1919

Yeni Üye
Katılım
25 Kas 2021
Mesajlar
7
En iyi yanıt
0
Puanları
1
Yaş
41
Konum
ordu
Ad Soyad
ali
Office Versiyon
2013
Merhaba benim günlük olarak veri girişi yaptığım bir veri girişi sayfam var o günlük veriler sayfasında hücreye girilen tarihe göre o tarihte üretilen modelleri (soru işareti olan hücreler) hücreye formülle getirmeye ihtiyacım var.

Fakat o tarihte girilen aynı model numaralarını mesela 12.11.2021 tarihinde iki kez m21-321 varsa bir tanesini yazması gerek yani 1 gün içerisinde 5 farklı model varsa tarihe göre onu sırası soru işareti olan yere aktarmam gerek.

Yardımlarınız için şimdiden teşekkür ederim.
 

Ekli dosyalar

  • deneme veri girişi.xlsx
    40.5 KB · Görüntüleme: 6

muygun

Uzman
Katılım
19 Ağu 2018
Mesajlar
281
En iyi yanıt
25
Puanları
28
Konum
Excel 2003
Ad Soyad
Mustafa UYGUN
Office Versiyon
Office 2003
Merhaba;
Doğru anladıysam eki deneyin.
İyi çalışmalar.
 

Ekli dosyalar

  • alix1919-deneme veri girişi.zip
    28.9 KB · Görüntüleme: 4

alix1919

Yeni Üye
Katılım
25 Kas 2021
Mesajlar
7
En iyi yanıt
0
Puanları
1
Yaş
41
Konum
ordu
Ad Soyad
ali
Office Versiyon
2013
Merhaba ;
Çok başarılı olmuş çok teşekkür ediyorum.
ama tek bir eksik var o belirtilen tarihte aynı model numarası tekrarlanıyorsa sadece 1 model numarası yazılması gerek
Örnek :
tarihi 12.07.2021 yaptığımızda formülle belirttiğiniz yere m21-222 modeli 2 kez değil sadece 1 defa yazılması gerek.
çünkü tarih girildiğinde diğer veriler (operasyonlar ) m21-222 modeli için girilen değerlerin toplamını veriyor.

Özet olarak tarih girildiğinde aynı model kaç defa girilirse girilsin formül yazılan yere sadece 1 defa o modeli yazması gerek alt kısımda tekrar aynı model yazılmaması lazım bir nevi tek bir model toplam oranlar (toplam oranlar formüllü dür)

Umarım açıklaya bilmişimdir. Şimdiden teşekkür ediyorum.
Emeğinize ellerinize sağlık
 

muygun

Uzman
Katılım
19 Ağu 2018
Mesajlar
281
En iyi yanıt
25
Puanları
28
Konum
Excel 2003
Ad Soyad
Mustafa UYGUN
Office Versiyon
Office 2003
Merhaba;
Eki tekrar deneyin.
İyi çalışmalar.
 

Ekli dosyalar

  • alix1919-deneme veri girişi-1.zip
    29.3 KB · Görüntüleme: 12

alix1919

Yeni Üye
Katılım
25 Kas 2021
Mesajlar
7
En iyi yanıt
0
Puanları
1
Yaş
41
Konum
ordu
Ad Soyad
ali
Office Versiyon
2013
Merhaba Mustafa bey ;
sanırım bu defada olmadı :(
 

muygun

Uzman
Katılım
19 Ağu 2018
Mesajlar
281
En iyi yanıt
25
Puanları
28
Konum
Excel 2003
Ad Soyad
Mustafa UYGUN
Office Versiyon
Office 2003
Merhaba;
15.07.2021 deneme tarihine göre doğru sonuç veriyor.
Hatalı dosyayı ekleyin ve hata noktasını belirtin.
Tekrar bakalım.
İyi çalışmalar.
 

alix1919

Yeni Üye
Katılım
25 Kas 2021
Mesajlar
7
En iyi yanıt
0
Puanları
1
Yaş
41
Konum
ordu
Ad Soyad
ali
Office Versiyon
2013
Merhaba Mustafa bey ;

formülleri aşağıdaki gibi olduğu gibi kopyaladım

=EĞER(EHATALIYSA(İNDİS('VERİ GİRİŞİ'!$A:$AN;KAÇINCI('GÜNLÜK VERİLER'!$G$2&"_"&SATIR()-6;'VERİ GİRİŞİ'!$AN:$AN;0);1));"";İNDİS('VERİ GİRİŞİ'!$A:$AN;KAÇINCI('GÜNLÜK VERİLER'!$G$2&"_"&SATIR()-6;'VERİ GİRİŞİ'!$AN:$AN;0);1))

Ekte mevcut olan resimdeki gibi 23.11.2021 tarihli veri girişinde mevcut olan verileri veri girişi bölümüne tarihi yazdığımda sarı ve kırmızı renkte belirttiğim gibi aynı model tekrar hücreye yansımaktadır.

Aynı modellerin sadece 1 tane model numarasını hücreye yazdırması gerek ama diğer hücrelerde aynı model tekrarlanıyor.

Raporlama yapabilmem için bu önemli

Yardım ve anlayışınız için şimdiden teşekkürler.
 

Ekli dosyalar

  • VERİ GİRİŞİ.jpg
    VERİ GİRİŞİ.jpg
    431.5 KB · Görüntüleme: 7
  • GÜNLÜK  VERİLER.jpg
    GÜNLÜK VERİLER.jpg
    374.8 KB · Görüntüleme: 7

muygun

Uzman
Katılım
19 Ağu 2018
Mesajlar
281
En iyi yanıt
25
Puanları
28
Konum
Excel 2003
Ad Soyad
Mustafa UYGUN
Office Versiyon
Office 2003
hatalı sonuç veren excel dosyasını (hatalı şekliyle) yükleyin.
Önceki örneğinizde 23.11,2021 tarihli veri yok.!
Önceki örnekteki tarihleri kontrol ettim. (böyle bir sorun yok)
Belki tarih yazımınızda bir problem olabilir.
Dosyayı görmem gerek...
 

alix1919

Yeni Üye
Katılım
25 Kas 2021
Mesajlar
7
En iyi yanıt
0
Puanları
1
Yaş
41
Konum
ordu
Ad Soyad
ali
Office Versiyon
2013
Mustafa bey dosya boyutu çok fazla olduğu için yükleme yapamıyorum.
Önerebileceğiniz bir yer varsa oraya yükleme yapıp oradan kontrol etme şansımız varmıdır ?
 

muygun

Uzman
Katılım
19 Ağu 2018
Mesajlar
281
En iyi yanıt
25
Puanları
28
Konum
Excel 2003
Ad Soyad
Mustafa UYGUN
Office Versiyon
Office 2003
Marhaba;
VERİ GİRİŞİ sayfasında AL4 hücresindeki formülü aynen taşımamışsınız. (Formülde sabitleme yapmamışsınız.)
Formülü
=EĞER(EĞERSAY($AK$4:AK4;AK4)=1;AK4;"")
şeklinde düzenleyerek aşağı doğru çoğaltın.
İyi çalışmalar.
 

alix1919

Yeni Üye
Katılım
25 Kas 2021
Mesajlar
7
En iyi yanıt
0
Puanları
1
Yaş
41
Konum
ordu
Ad Soyad
ali
Office Versiyon
2013
Merhaba;
Mustafa bey şimdi durum düzeldi yardımlarınız ve göstermiş olduğunuz ilgi alakadan dolayı çok teşekkür ederim.
İyi çalışmalar.
 
Üst Alt