Yardım aşırı yavaş çalışan formül

incsoft

Yeni Üye
Katılım
28 Ocak 2019
Mesajlar
142
En iyi yanıt
0
Puanları
18
Yaş
40
Konum
Ankara
Ad Soyad
Ufuk İNCE
Office Versiyon
Office 2019 Professional
Arkadaşlar L2.....250 ve C3.........250 ye göre iki alana göre sorgulama yaptırdığım formülüm aşağıdadır ancak neden se çok aşırı yavaş çalışmaktadır. Bunu hızlı bir şekilde çalışan başka bir formüle dönüştürebilirmiyiz?

Teşekkürler..

=EĞERHATA(İNDİS(DATA!G:G;TOPLA.ÇARPIM((KAÇINCI(C3&"@"&$L$2;DATA!A:A&"@"&DATA!J:J;0))));"0")
 

incsoft

Yeni Üye
Katılım
28 Ocak 2019
Mesajlar
142
En iyi yanıt
0
Puanları
18
Yaş
40
Konum
Ankara
Ad Soyad
Ufuk İNCE
Office Versiyon
Office 2019 Professional
örnek arkadaşlar.
 

Ekli dosyalar

  • soru.xlsx
    13.6 KB · Görüntüleme: 1

Mahir64

Yeni Üye
Katılım
21 Nis 2021
Mesajlar
69
En iyi yanıt
3
Puanları
8
Konum
Uşak
Ad Soyad
Mahir
Office Versiyon
2016 TR
Merhaba,

Mantık değişmeyecekse ÇOKETOPLA kullanabilirsiniz.
Kod:
=+ÇOKETOPLA(DATA!G:G;DATA!A:A;A2;DATA!J:J;$J$1)

Kendi formülünüzle devam edecekseniz, TOPLA.ÇARPIM formülünde aralık belirtin. DATA!A1:A1000&"@"&DATA!J1:J1000;0))));"0") şeklinde değiştirin.
 
Üst Alt