• Merhaba Ziyaretçi,
    Microsoft 365 Uygulamaları ile ilgili yeni haberler, dikkat çekici konular, ilgi ile takip edeceğiniz yazılar için.

    Abone Olun
  • ESTE - Microsoft Office Eğitimleri

    Yeni yıl Microsoft Office Eğitim planlarınız için bütçenizi oluşturmadan önce ESTE eğitim kalitesi ile tanışın. 🙌
    Kullanıcıların ihtiyacı olan yazılı materyal, dosya ve video kaynağı desteğimiz ile tüm ofis çalışanlarının iş süreçlerini rahatlatacak eğitimler planlayın. 🎯
    Microsoft Office eğitimlerimiz hakkında detaylı bilgi için bize ulaşın.

    👉 Microsoft Office Eğitim Talebi

Yardım Birden Fazla Koşula Göre Değer Getirme

hayalibey

Yeni Üye
Katılım
5 Nis 2019
Mesajlar
18
En iyi yanıt
0
Puanları
1
Yaş
40
Konum
Ankara
Ad Soyad
Mahmut YILDIZ
Office Vers.
Ofis 2016 TR 64 Bit
Herkese kolay gelsin benim şöyle bir sorunum var:
ŞARTLAR:
GÖREV sayfadaki F7 hücresi TRAFOCU Sayfasında A sütününda herhangi bir yerde var mı (her biri iki tane var)
ve GÖREV sayfasının J7 hücresi TRAFOCU Sayfasının B sütünunda var ise (birden fazla var aynısını)

ve GÖREV sayfasının L7 hücresi TRAFOCU Sayfasının C sütünunda var ise (birden fazla var aynısını)

bu üç şart yerine bağlı ise

SONUÇ:
TRAFOCU Sayfayı E sütünüdaki satırda bulunan tam olarak adlandırılmış değerin (isim yazdığım alan -hücre) GÖREV sayfanız E59 hücresine yazıyor istiyorum. (Sarı renkle boyayıp çerçeve yaptım.)
 

Ekli dosyalar

  • GÖREV LİSTESİ.xlsm
    65.5 KB · Görüntüleme: 5

hayalibey

Yeni Üye
Katılım
5 Nis 2019
Mesajlar
18
En iyi yanıt
0
Puanları
1
Yaş
40
Konum
Ankara
Ad Soyad
Mahmut YILDIZ
Office Vers.
Ofis 2016 TR 64 Bit
=İNDİS(TRAFOCU!E:E;KAÇINCI(1;(TRAFOCU!A:A=GÖREV!F7)*(TRAFOCU!B:B=GÖREV!J7)*(TRAFOCU!C:C=GÖREV!L7);0))

Sayın @cakarem beyin yardımı ile çözülmüştür. Kendisine teşekkür ederim.
 

komutan63

Yeni Üye
Katılım
21 Haz 2018
Mesajlar
10
En iyi yanıt
1
Puanları
3
Yaş
60
Konum
Ankara
Ad Soyad
Muzaffer Demir
Office Vers.
Ofis 2010
Selamlar
Alternatif olsun
E59 Hücresine:
Kod:
=EĞERHATA(İNDİS(TRAFOCU!$E$474:$E$620;TOPLA.ÇARPIM(KAÇINCI(GÖREV!F7&"@"&GÖREV!J7&"@"&GÖREV!L7;TRAFOCU!A474:A620&"@"&TRAFOCU!B474:B620&"@"&TRAFOCU!C474:C620;0)));"")
 

hayalibey

Yeni Üye
Katılım
5 Nis 2019
Mesajlar
18
En iyi yanıt
0
Puanları
1
Yaş
40
Konum
Ankara
Ad Soyad
Mahmut YILDIZ
Office Vers.
Ofis 2016 TR 64 Bit
Selamlar
Alternatif olsun
E59 Hücresine:
Kod:
=EĞERHATA(İNDİS(TRAFOCU!$E$474:$E$620;TOPLA.ÇARPIM(KAÇINCI(GÖREV!F7&"@"&GÖREV!J7&"@"&GÖREV!L7;TRAFOCU!A474:A620&"@"&TRAFOCU!B474:B620&"@"&TRAFOCU!C474:C620;0)));"")
Değer yoksa #yok yerine hiç bir şey yazmasın desek nasil olacak
 

hayalibey

Yeni Üye
Katılım
5 Nis 2019
Mesajlar
18
En iyi yanıt
0
Puanları
1
Yaş
40
Konum
Ankara
Ad Soyad
Mahmut YILDIZ
Office Vers.
Ofis 2016 TR 64 Bit
Bir de satırlar gizli siz 474 ten aldınız ama 1 0cakrqn başlayan satırlar şeklinde kodu revize edip eger karşılık yokda hiç bir sey yazmasın şeklinde olsa
 

hayalibey

Yeni Üye
Katılım
5 Nis 2019
Mesajlar
18
En iyi yanıt
0
Puanları
1
Yaş
40
Konum
Ankara
Ad Soyad
Mahmut YILDIZ
Office Vers.
Ofis 2016 TR 64 Bit
Herkese merhaba size de sayin @komutan63 çalışma sistemini 08:00 den başlatıp ertesi gün 08:00e kadar devam ettirerek Trafocu sayfasında döndürebilir miyiz peki Misal
Mesai ekteki TRAFO sayfasında görüldüğü gibi ama şöyle
23.08.2019 da 08:00 de başlıyor
24.08.2019 08.00de bitiyor ve bir gru 3 kişi
diğer grup 2 kişi
sorumlu personel Trafo Personeli oluyor
Diğer personel sıra ile Trafo personeli olacak ama çalıştığı kendi gününde
2 grup var her grup 24 saat çalışıp 24 saat istirahat ediyor ve 08.00 de başayıp ertesi gün 08.00 de bitiyor görev
SONUÇ
personel 3 kişi ise 3 personel de sıra ile trafo personeli olacak
Eğer 2 kişi ise ikinci diğer personel yazan yer boş ise
başa dönecek 2 personel de sıra ile Trafo personeli olacak İlerde 3 personel olursa yani ikinci diğer personel dolu olursa 3 personel şeklinde dönecek
Buradaki ayrıntı makro tarih olarak 24 saat çalışma 24 saat istirahat olacak şekilde çalışacak ve 08.00den itibaren dönüşümlü görevi dağıtacak ta ki ertesi gün 06.00-08.00 de görev bitecek şekilde
Ertesi gün 06.00-08.00 da başlayan görevi alacak
Ertesi gün 08.00-10.00 trafo personeli görevi diğer gruba devrecek ve onun sıra gelen personeli trafo personeli olacaktır
tabloda kısa bir örnek verdim
https://codespace.pw/attachments/gorev-listesi-xlsm.2133/?__cpo=aHR0cHM6Ly9leGNlbGRlc3Rlay5jb20
 

Ekli dosyalar

  • GÖREV LİSTESİ (1).xlsm
    62.8 KB · Görüntüleme: 6

komutan63

Yeni Üye
Katılım
21 Haz 2018
Mesajlar
10
En iyi yanıt
1
Puanları
3
Yaş
60
Konum
Ankara
Ad Soyad
Muzaffer Demir
Office Vers.
Ofis 2010
Kod içinde ki 474 ile başlayan 620 ile biten yerleri dosyanıza göre değiştirebilirsiniz.
 

hayalibey

Yeni Üye
Katılım
5 Nis 2019
Mesajlar
18
En iyi yanıt
0
Puanları
1
Yaş
40
Konum
Ankara
Ad Soyad
Mahmut YILDIZ
Office Vers.
Ofis 2016 TR 64 Bit
Değiştiğini yaptım ama ben Görev sayfani GÖREV ALANI 1 yaptım kodu çalıştıramadım.
 

komutan63

Yeni Üye
Katılım
21 Haz 2018
Mesajlar
10
En iyi yanıt
1
Puanları
3
Yaş
60
Konum
Ankara
Ad Soyad
Muzaffer Demir
Office Vers.
Ofis 2010
Selamlar
E59 Hücresine:
Alternatif1:
Kod:
=İNDİS(TRAFOCU!$E$3:$E$1000;TOPLA.ÇARPIM(KAÇINCI(GÖREV!F7&"@"&GÖREV!J7&"@"&GÖREV!L7;TRAFOCU!$A$3:$A$1000&"@"&TRAFOCU!B3:B1000&"@"&TRAFOCU!C3:C1000)))

E59 Hücresine:
Alternatif 2:
Kod:
CTRL+SHİFT+ENTER ile
=İNDİS(TRAFOCU!$E$3:$E$1000;KAÇINCI(1;(TRAFOCU!A3:A1000=GÖREV!F7)*(TRAFOCU!B3:B1000=GÖREV!J7)*(TRAFOCU!C3:C1000=GÖREV!L7);0))

Not: Formülde GÖREV yazan yerleri GÖREV ALANI 1 ile değiştir.
 
Üst Alt