Yardım Diğer sayfadan Koda göre ürün adını yanına yazdırma.

yusuf.ayan

Yeni Üye
Katılım
21 Nis 2021
Mesajlar
30
En iyi yanıt
0
Puanları
8
Yaş
38
Konum
istanbul
Ad Soyad
Yusuf AYAN
Office Versiyon
OFFİCE 2016 TR
Arkadaşlar kolay gelsin şimdiden teşekkür ederim .Ben bir user form yaptım bu forumda sadece ürün kodu ve STK(Son Kullanım Tarihi) girişi yapıyorum ve kaydettikten sonda 1. sütuna kodu 3.sütuna da STK yi girdiriyorum burda sıkıntı yok sıkıntım şu kaydede tıkladıktan sonra malzemenin adını aynı sayfada bulunan TAMLİSTE den o koda ait malzemenin adını 2.sütüna otomatik kendi yazsın istiyorum ama yapamadım çok uğraştım düşeyara yı kullandım sürekli yok hatası alıyorum hücre özelliklerini aynı yaptım ama olmadı yardımcı olursanız çok sevinirim şimdiden teşekkürler.
 

Ekli dosyalar

  • STKTAKİBİ.xlsm
    78.5 KB · Görüntüleme: 2

azraep

Yeni Üye
Katılım
29 Eki 2020
Mesajlar
101
En iyi yanıt
2
Puanları
28
Yaş
74
Konum
İstanbul
Ad Soyad
Azra
Office Versiyon
Office 2019 TR
umarım işinizi görür
 

Ekli dosyalar

  • STKTAKİBİ.xlsm
    98 KB · Görüntüleme: 4

yusuf.ayan

Yeni Üye
Katılım
21 Nis 2021
Mesajlar
30
En iyi yanıt
0
Puanları
8
Yaş
38
Konum
istanbul
Ad Soyad
Yusuf AYAN
Office Versiyon
OFFİCE 2016 TR
Kardeşim ellerine sağlık olmuş ama şu hatayı veriyor kodu girince her seferinde Stoklarda Böyle Bir Kayıt Yok..! hatasını veriyor çıkış butonuna kayıtlı ama veriyor kaydederken
 

azraep

Yeni Üye
Katılım
29 Eki 2020
Mesajlar
101
En iyi yanıt
2
Puanları
28
Yaş
74
Konum
İstanbul
Ad Soyad
Azra
Office Versiyon
Office 2019 TR
Şimdi olacak inşallah.
 

Ekli dosyalar

  • STKTAKİBİ.xlsm
    100.4 KB · Görüntüleme: 4

yusuf.ayan

Yeni Üye
Katılım
21 Nis 2021
Mesajlar
30
En iyi yanıt
0
Puanları
8
Yaş
38
Konum
istanbul
Ad Soyad
Yusuf AYAN
Office Versiyon
OFFİCE 2016 TR
Kardeşim emeğine sağlık senide çok uğraştırdım ama olmamış ya bu seferde çıkışa bastığın zaman kod kısmı boş geçilemez hatası veriyor daha doğrusu kaydet işlemi haricinde hangi işlemi yaparsan önceli olarak hata veriyor..
 

azraep

Yeni Üye
Katılım
29 Eki 2020
Mesajlar
101
En iyi yanıt
2
Puanları
28
Yaş
74
Konum
İstanbul
Ad Soyad
Azra
Office Versiyon
Office 2019 TR
Rica ederim. Elimden geleni yapmaya çalışıyorum. biraz daha düzelttim gibi.
 

Ekli dosyalar

  • STKTAKİBİ.xlsm
    98.3 KB · Görüntüleme: 2

yusuf.ayan

Yeni Üye
Katılım
21 Nis 2021
Mesajlar
30
En iyi yanıt
0
Puanları
8
Yaş
38
Konum
istanbul
Ad Soyad
Yusuf AYAN
Office Versiyon
OFFİCE 2016 TR
Kardeşim ellerine sağlık olmuş gibi gözüküyor son bir şey isteyebilir miyim seni online yakalamışken:) daha önce girilmiş kod var ise tekrar girildiğinde bu kod daha önce girilmiştir uyarısı verdirebilir misin :)
 

azraep

Yeni Üye
Katılım
29 Eki 2020
Mesajlar
101
En iyi yanıt
2
Puanları
28
Yaş
74
Konum
İstanbul
Ad Soyad
Azra
Office Versiyon
Office 2019 TR
Bi kontrol eder misin?
 

Ekli dosyalar

  • STKTAKİBİ.xlsm
    102.9 KB · Görüntüleme: 1

yusuf.ayan

Yeni Üye
Katılım
21 Nis 2021
Mesajlar
30
En iyi yanıt
0
Puanları
8
Yaş
38
Konum
istanbul
Ad Soyad
Yusuf AYAN
Office Versiyon
OFFİCE 2016 TR
uyarıyı veriyor ama kardeşim şimdide ürün kaydı yaparken hata veriyor cok yordum seni ya hakkını helal et..
 

azraep

Yeni Üye
Katılım
29 Eki 2020
Mesajlar
101
En iyi yanıt
2
Puanları
28
Yaş
74
Konum
İstanbul
Ad Soyad
Azra
Office Versiyon
Office 2019 TR
Estafurullah. elimizden geldince yardım etmeye çalışıyorum.
soruna gelecek olursa

C#:
Private Sub CommandButton_KYDT_Click()
    
    içindeki
    
    aranan = Range("A:A").Find(TextBox_KOD.Value)
    
    satırını silersen sorun çözülür.
 

Mahir64

Yeni Üye
Katılım
21 Nis 2021
Mesajlar
13
En iyi yanıt
2
Puanları
3
Konum
Uşak
Ad Soyad
Mahir
Office Versiyon
2016 TR
Merhaba,
Düşeyara hata verme sebebi: "TAMLİSTE"'deki kodların metin olması. (Kenarı yeşil)
Mevcut haliyle devam edecekseniz ağaşıdaki formülü kullanın.
Kod:
=DÜŞEYARA(METNEÇEVİR(A2;"######");'TAMLİSTE '!A1:B1157;2;0)

Sayı olarak biçimlendirecekseniz, (F2+Enter yapmanız yeterli.)
Kod:
=DÜŞEYARA(A2;'TAMLİSTE '!A1:B1157;2;0)
 

yusuf.ayan

Yeni Üye
Katılım
21 Nis 2021
Mesajlar
30
En iyi yanıt
0
Puanları
8
Yaş
38
Konum
istanbul
Ad Soyad
Yusuf AYAN
Office Versiyon
OFFİCE 2016 TR
İlginiz için teşekkür ederim.
 

yusuf.ayan

Yeni Üye
Katılım
21 Nis 2021
Mesajlar
30
En iyi yanıt
0
Puanları
8
Yaş
38
Konum
istanbul
Ad Soyad
Yusuf AYAN
Office Versiyon
OFFİCE 2016 TR
Peki şimdi ben kodu girdim stk yı da girdim kaydet dedim sayfaya yazdıktan sonra o satıra otomatik biçimlendirme yapabiliriyim acaba :) her girişte
 

yusuf.ayan

Yeni Üye
Katılım
21 Nis 2021
Mesajlar
30
En iyi yanıt
0
Puanları
8
Yaş
38
Konum
istanbul
Ad Soyad
Yusuf AYAN
Office Versiyon
OFFİCE 2016 TR
Çok olacak ama :D hakkını helal et hepsi STK sı 90 Günden aşağıda olanlar hücreler kırmızı 90-270 arası sarı diğerleri yeşil :)
 

azraep

Yeni Üye
Katılım
29 Eki 2020
Mesajlar
101
En iyi yanıt
2
Puanları
28
Yaş
74
Konum
İstanbul
Ad Soyad
Azra
Office Versiyon
Office 2019 TR
Koşullu biçimlendirme ile denedim ama bir türlü başaramadım.
Becerebilirsem dosyayı atarım.
 

azraep

Yeni Üye
Katılım
29 Eki 2020
Mesajlar
101
En iyi yanıt
2
Puanları
28
Yaş
74
Konum
İstanbul
Ad Soyad
Azra
Office Versiyon
Office 2019 TR
Anca bunu becerebildim.
 

Ekli dosyalar

  • STKTAKİBİ.xlsm
    107.8 KB · Görüntüleme: 4

yusuf.ayan

Yeni Üye
Katılım
21 Nis 2021
Mesajlar
30
En iyi yanıt
0
Puanları
8
Yaş
38
Konum
istanbul
Ad Soyad
Yusuf AYAN
Office Versiyon
OFFİCE 2016 TR
Emeğine sağlık kardeşim ama bunu kastetmemiştim. Bunu koşullu biçimlendirme ile yapabiliyorum aslında ben şundan bahsetmiştim. Giriş yapıldıktan sonra değere göre otomatik olarak o satırın rengini değiştirebilir miyiz diye formüller vs
 

wexplorerx

Yeni Üye
Katılım
9 Tem 2019
Mesajlar
74
En iyi yanıt
3
Puanları
8
Konum
İstanbul
Ad Soyad
Murat Uzun
Office Versiyon
Office 2016
Merhaba
Dosyadan deneyebilirsiniz.
 

Ekli dosyalar

  • STKTAKİBİ.xlsm
    98.9 KB · Görüntüleme: 2

yusuf.ayan

Yeni Üye
Katılım
21 Nis 2021
Mesajlar
30
En iyi yanıt
0
Puanları
8
Yaş
38
Konum
istanbul
Ad Soyad
Yusuf AYAN
Office Versiyon
OFFİCE 2016 TR
Kardeşim eline sağlık güzel olmuş bir şey daha rica edebilir miyim ben şimdi kalan süreyi formulle yapıyorum ya altta boş satırlar dada formulu kopyaladığım zaman -444310 diye rakam gözüküyor kalan süre yi de makro ile hesaplata bilirmiyim acaba boş satırda formul kalmasın diye
 
Üst Alt