Çözüldü Düşeyara ile Diğer Sütunlardaki Verileri de Getirmek

Durum
Üzgünüz bu konu cevaplar için kapatılmıştır...

Ahmet Saatci

Yeni Üye
Katılım
29 May 2018
Mesajlar
8
En iyi yanıt
0
Puanları
3
Konum
İstanbul
Merhaba
Düşeyara formülünü çoğunlukla kullanıyoruz.
Aradığımız değeri tablomuzda bulup istediğimiz sütundaki veriyi getirebiliyoruz ama tek sütun getiriyor.
Sağa doğru çektiğimizde diğer sütunlardaki verileri de getirmesini nasıl sağlayabiliriz?
 

Murat OSMA

Yönetici
Site Yöneticisi
Katılım
25 May 2018
Mesajlar
1,318
En iyi yanıt
11
Puanları
113
Konum
İstanbul
Web sitesi
excelarsivi.com
Ad Soyad
Murat OSMA
Office Versiyon
Office 365 TR+EN
Merhaba Sn. @Ahmet Saatci,

Diğer sütunlardaki verileri de sağa doğru çekerek getirmek için, Düşeyara fonksiyonundaki sütun_indis_sayısı argümanını değişken yapmanız gerekir. Değişkenden kastım şudur; hücredeki formülü sağa doğru çektiğinizde sütun_indis_sayısı argümanındaki sayınını da otomatik olarak artmasını sağlamaktır.

Bunu durumu sağlayabileceğiniz SÜTUN adında bir fonksiyon mevcut. SÜTUN fonksiyonu iki şekilde çalışır; ya bir hücre seçip=SÜTUN(B1) referans olarak o hücreyi belirtirsiniz, ya da =SÜTUN() yazarak, hangi hücreye yazdıysanız o hücrenin sütun indeks sayısını almasını sağlayabilirsiniz.

Diyelim ki; aşağıdaki gibi 4 sütundan oluşan bir tablonuz var ve siz formülü yazıp sağa doğru çektiğinizde, sırasıyla tablodaki 2, 3 ve 4. sütundaki verilerin de gelmesini istiyorsunuz.
ADISOYADIYAŞIDOĞUM YERİ

Murat

OSMA

33

Gümüşhane

Emre

OSMA

26

Ankara

Arzu

ZENGİN

45

Eskişehir

Burak

ALBAYRAK

32

İzmir

Emel

True

15

G.Antep

Murat

KARAKUŞ

20

Adana

F2 hücresine aranan değeri yazın, aşağıda belirtilen formülü de G2 hücresine yapıştırıp sağa doğru çekerek istediğiniz verileri getirebilirsiniz.
ADISOYADI

Arzu

=DÜŞEYARA($F$2;$A$1:$D$7;SÜTUN(B1);0)

Saygılar
 

anemis

Yeni Üye
Katılım
13 Haz 2018
Mesajlar
22
En iyi yanıt
0
Puanları
3
Yaş
37
Konum
ANKARA
Web sitesi
www.vartamuhendislik.com.tr
Ad Soyad
Tarık VAROL
Merhaba
Düşeyara formülünü çoğunlukla kullanıyoruz.
Aradığımız değeri tablomuzda bulup istediğimiz sütundaki veriyi getirebiliyoruz ama tek sütun getiriyor.
Sağa doğru çektiğimizde diğer sütunlardaki verileri de getirmesini nasıl sağlayabiliriz?

Merhaba,

Admin arkadaşın affına sığınarak, örnek basit bir dosya yüklerseniz size uygun şekilde formülasyonu yazarak yardımcı olmaya çalışalım.
 

Ahmet Saatci

Yeni Üye
Katılım
29 May 2018
Mesajlar
8
En iyi yanıt
0
Puanları
3
Konum
İstanbul
Teşekkürler @Admin, belirttiğiniz gibi sütun formülüyle istediğim oldu. :)
ayrıntılı bilgiler için ayrıca teşekkür ederim.
 
Durum
Üzgünüz bu konu cevaplar için kapatılmıştır...
Üst Alt