Yardım Düşeyara ve çok eğer formülünün birlikte kullanımı

frtytkn

Yeni Üye
Katılım
29 Ocak 2020
Mesajlar
1
En iyi yanıt
0
Puanları
1
Yaş
31
Konum
İstanbul
Ad Soyad
Fırat Yetkin
Öncelikle herkese iyi forumlar dilerim. Excel 2010'da birden çok satırda doğrulama yapacak ve hepsi doğru ise sonuç verecek bir formül oluşturmak istiyorum. Daha açıklayıcı olma adına aşağıda detaylı aktarıyorum;

Verilerin olduğu bir tablo var ve bu tabloyu "veri_tablo" diye adlandıralım. Bu "veri_tablo"da da sütun1, sütun2, sütun3, sütun4 diye devam eden sütunlar var. Buna göre;
1) B2 hücresindeki değer "veri_tablo"da bulunan sütun1 deki değerleri tarayıp aynı olanı bulacak. Sonra,
2) D4 hücresindeki değer "veri_tablo"da bulunan sütun3 deki değerleri tarayıp aynı olanı bulacak. Sonra,
3) I4 hücresindeki değer "XYZ" metni ile aynıysa, daha önce taradığı iki eşleşmenin satırında olan ve sütun5 deki değerleri tarayıp, doğru veriyi M4 hücresine getirecek. Eğer bir eşleşme olmaza M4 hücresindeki değer 0 olacak.

Mantıksal olarak "eğer" ve "ve" formülleri ile yapmaya çalıştım ancak "veri_tablo"da ki sadece ilk satırdaki veriyi çekebiliyorum.
=EĞER(VE(D4=ithal_parcalar[Parça Tipi];B2=ithal_parcalar[Model Kod];I4="İTHAL");ithal_parcalar[Fiyat];0)

Şimdiden teşekkür ederim.
 
Üst Alt