Yardım formül sonrası komutları macro ile otomatik silme

incsoft

Yeni Üye
Katılım
28 Ocak 2019
Mesajlar
157
En iyi yanıt
0
Puanları
18
Yaş
40
Konum
Ankara
Ad Soyad
Ufuk İNCE
Office Versiyon
Office 2019 Professional
Aşağıdaki gibi formüle benzer formüller formumda bulunan D151,D152,D153,D154,D155,D156,E151,E152,E153,E154,E155,E156,E158 hücrelerinde mevcuttur ancak bazı durumlarda ister istemez sonuna -1500+500 ya da +1500+1250 vb.. eklentiler yapabilmekteyim. Bunu macrolarla otomatik olarak bu hücrelerdeki formüllerin sonunda bulunan işlemleri nasıl temizletebilirim arkadaşlar?

Mesela aşağıdaki

=TOPLA.ÇARPIM((L3:L12=A151)*(M3:M12))+TOPLA.ÇARPIM((L44:L72=A151)*(M44:M72))+TOPLA.ÇARPIM((L83:L138=A151)*(M83:M138))-1500+500 formülünü

=TOPLA.ÇARPIM((L3:L12=A151)*(M3:M12))+TOPLA.ÇARPIM((L44:L72=A151)*(M44:M72))+TOPLA.ÇARPIM((L83:L138=A151)*(M83:M138)) yapacak

ya da

=TOPLA.ÇARPIM((L3:L12=A151)*(M3:M12))+TOPLA.ÇARPIM((L44:L72=A151)*(M44:M72))+TOPLA.ÇARPIM((L83:L138=A151)*(M83:M138))+1500+1250 formülünü

=TOPLA.ÇARPIM((L3:L12=A151)*(M3:M12))+TOPLA.ÇARPIM((L44:L72=A151)*(M44:M72))+TOPLA.ÇARPIM((L83:L138=A151)*(M83:M138)) yapacak..
 

incsoft

Yeni Üye
Katılım
28 Ocak 2019
Mesajlar
157
En iyi yanıt
0
Puanları
18
Yaş
40
Konum
Ankara
Ad Soyad
Ufuk İNCE
Office Versiyon
Office 2019 Professional
Sub formul_hy()
k = InStrRev(Range("D151,D152,D153,D154,D155,D156,E151,E152,E153,E154,E155,E156,E158").Formula, ")")
al = Mid(Range("D151,D152,D153,D154,D155,D156,E151,E152,E153,E154,E155,E156,E158 ").Formula, 1, k)
Range("D151,D152,D153,D154,D155,D156,E151,E152,E153,E154,E155,E156,E158 ").Formula = al
End Sub


bununla çözüm ancak daha seri bir yöntem varsa öğrenebilirim arkadaşlar..
 
Üst Alt