• Merhaba Ziyaretçi,
    Microsoft 365 Uygulamaları ile ilgili yeni haberler, dikkat çekici konular, ilgi ile takip edeceğiniz yazılar için.

    Abone Olun
  • ESTE - Microsoft Office Eğitimleri

    Yeni yıl Microsoft Office Eğitim planlarınız için bütçenizi oluşturmadan önce ESTE eğitim kalitesi ile tanışın. 🙌
    Kullanıcıların ihtiyacı olan yazılı materyal, dosya ve video kaynağı desteğimiz ile tüm ofis çalışanlarının iş süreçlerini rahatlatacak eğitimler planlayın. 🎯
    Microsoft Office eğitimlerimiz hakkında detaylı bilgi için bize ulaşın.

    👉 Microsoft Office Eğitim Talebi

Çözüldü Formülü koda dönüştürme

Durum
Üzgünüz bu konu cevaplar için kapatılmıştır...

lion2577

Yeni Üye
Katılım
3 Tem 2018
Mesajlar
13
En iyi yanıt
0
Puanları
3
Yaş
43
Konum
denizli
Ad Soyad
Yasin
Arkadaşlar merhaba aşağıda yazdığım formülleri ayrı ayrı koda nasıl dönüştürebilirim Yardımlarınızı bekliyorum.

=EĞER(BAĞ_DEĞ_SAY(BUL(" ";A2;BUL(" ";A2)+1))>0;SOLDAN(A2;BUL(" ";A2;BUL(" ";A2)+1)-1);SOLDAN(A2;BUL(" ";A2)-1))

=PARÇAAL(A2;UZUNLUK(B2)+2;UZUNLUK(A2)-UZUNLUK(B2))
 

Murat OSMA

Yönetici
Site Yöneticisi
Katılım
25 May 2018
Mesajlar
1,486
En iyi yanıt
13
Puanları
113
Konum
İstanbul
Web sitesi
excelarsivi.com
Ad Soyad
Murat OSMA
Office Vers.
Office 365 TR+EN
Merhaba @lion2577,

Bu şekilde formülün kod karşılığını oluşturmaktansa, dosyanızdaki verilere, yapılacak işleme göre bir kod yazılması daha uygun olacaktır.
Örnek dosyanızı eklerseniz bakalım.
 

lion2577

Yeni Üye
Katılım
3 Tem 2018
Mesajlar
13
En iyi yanıt
0
Puanları
3
Yaş
43
Konum
denizli
Ad Soyad
Yasin
Öncelikle ilginiz için çok teşekkür ederim. Örnek dosya ekde olup yardımlarınızı bekliyorum.
 

Ekli dosyalar

  • Excel-Ad-Soyad-Ayirmak.xls
    20 KB · Görüntüleme: 11
Son düzenleme:

Murat OSMA

Yönetici
Site Yöneticisi
Katılım
25 May 2018
Mesajlar
1,486
En iyi yanıt
13
Puanları
113
Konum
İstanbul
Web sitesi
excelarsivi.com
Ad Soyad
Murat OSMA
Office Vers.
Office 365 TR+EN
Bu kodları kullanabilirsiniz.

PHP:
Sub ExcelTurkey()
    Dim i%, ayir
    For i = 1 To Range("A65536").End(3).Row
        ayir = Split(Cells(i, 1).Value, " ")
        Cells(i, "C").Value = ayir(UBound(ayir))
        Cells(i, "B").Value = Replace(Cells(i, 1).Value, Cells(i, 3).Value, "")
    Next i
    i = Empty: Erase ayir
End Sub
 
Durum
Üzgünüz bu konu cevaplar için kapatılmıştır...
Üst Alt