Yardım Hücredeki Değerin Aynısından Varsa Yeniden Adlandırma

PPLUmbus

Yeni Üye
Katılım
17 Haz 2021
Mesajlar
5
En iyi yanıt
0
Puanları
3
Yaş
30
Konum
istanbul
Ad Soyad
deniz piskin
Office Versiyon
microsoft office profesyonel plus 2010
Merhabalar a sütünunda;
1- 12121727627
2- 17111728907
3- 11217786998
4- 11217786998
5- 11217787000
6- 11217787000
7- 11247790515
8- 11247790515
numaraları var.. ben b1 hücresine öyle bir kod yazmak istiyorum ki a sütunundaki değerlerin aynısından varsa yan hücreye parça numarasının sonuna 001 ekleyecek, 001 de varsa 002 ekleyecek onun da aynısından varsa 003.. 004.. diye devam edecek.(max 007 ye kadar gider muhtemelen)

örnek;
12121727627 den hiç olmadığı için 1212727627 olarak kalacak
11247790515 den 2 tane olduğu için bir tanesi 11247790515001 olacak diğeri aynı 11247790515 olarak kalacak.

Bunlar parça numaraları, bir parçayı 4-5 ayrı marka yapmış olabiliyor. hem orjinal parça numarasını kullanıp hem de karışmasınlar istiyorum o yüzden bu şekilde yapıyorum.

Nasıl yapabilirim? Yardımlarınızı rica ediyorum : )
 

azraep

Yeni Üye
Katılım
29 Eki 2020
Mesajlar
130
En iyi yanıt
2
Puanları
28
Yaş
75
Konum
İstanbul
Ad Soyad
Azra
Office Versiyon
Office 2019 TR
umarım işinizi görür.
 

Ekli dosyalar

  • ParcaNo.xlsx
    10 KB · Görüntüleme: 5

Mahir64

Yeni Üye
Katılım
21 Nis 2021
Mesajlar
40
En iyi yanıt
2
Puanları
8
Konum
Uşak
Ad Soyad
Mahir
Office Versiyon
2016 TR
Merhaba,

Deneyiniz. Alternatif olsun.
Kod:
=EĞER(EĞERSAY(A$1:A1;A1)=1;A1;A1&METNEÇEVİR(EĞERSAY(A$1:A1;A1)-1;"000"))
 

PPLUmbus

Yeni Üye
Katılım
17 Haz 2021
Mesajlar
5
En iyi yanıt
0
Puanları
3
Yaş
30
Konum
istanbul
Ad Soyad
deniz piskin
Office Versiyon
microsoft office profesyonel plus 2010
Çok teşekkür ederim baya işimi gördü emeklerinize sağlık.
 

Mahir64

Yeni Üye
Katılım
21 Nis 2021
Mesajlar
40
En iyi yanıt
2
Puanları
8
Konum
Uşak
Ad Soyad
Mahir
Office Versiyon
2016 TR
İyi çalışmalar.
 

azraep

Yeni Üye
Katılım
29 Eki 2020
Mesajlar
130
En iyi yanıt
2
Puanları
28
Yaş
75
Konum
İstanbul
Ad Soyad
Azra
Office Versiyon
Office 2019 TR
Rica ederim
 
Üst Alt