Çözüldü çoklu sorgulama

Durum
Üzgünüz bu konu cevaplar için kapatılmıştır...

incsoft

Yeni Üye
Katılım
28 Ocak 2019
Mesajlar
42
En İyi Yanıtlar
1
Beğeniler
2
Puanları
8
Yaş
38
Konum
Ankara
Ad Soyad
Ufuk İNCE
#1
Arkadaşlar C sütununa verileri DATA kısmından getirtmek istiyorum. Burada tek istediğim CUMA günleri V2 olanları sadece DATA C sütünundan buldurmak olacaktır. İşleyiş şu şekilde olacaktır,

Duruş tarihinin günü eğerki cuma ise , vardiya da V2 ise , işyerini DATA A sütunundan sorgula DATA C karşılığını yaz değilse DATA B karşılığını getir.

Buradada Duruş tarihi , Vardiya , İşyeri alanlarını da VERİ kısmından farklı metodla getirtmek isterim ancak yapamadım.
Buna başka bir çözüm olmazsa bu şekilde en son bir buton koyarak sorgulama yaptığı alanları sadece farklı bir sayfaya birebir aktarabilirmiyim? Mesela bugünkü verilere göre =A1:J196 aralığını farklı bir alana koplayaması gerekmektedir.
 

Ekli dosyalar

Admin

Yönetici
Site Yöneticisi
Katılım
25 May 2018
Mesajlar
1,054
En İyi Yanıtlar
77
Beğeniler
855
Puanları
113
Konum
İstanbul
#2
Merhaba,
C2 hücresine bu formülü yazıp aşağıya doğru çekerek deneyiniz..
VBA:
=EĞER(VE(HAFTANINGÜNÜ($B2;2)=5;$D2="V2");DÜŞEYARA($H2;DATA!$A$1:$C$256;3;0);DÜŞEYARA($H2;DATA!$A$1:$C$256;2;0))
 

incsoft

Yeni Üye
Katılım
28 Ocak 2019
Mesajlar
42
En İyi Yanıtlar
1
Beğeniler
2
Puanları
8
Yaş
38
Konum
Ankara
Ad Soyad
Ufuk İNCE
#3
Merhaba,
C2 hücresine bu formülü yazıp aşağıya doğru çekerek deneyiniz..
VBA:
=EĞER(VE(HAFTANINGÜNÜ($B2;2)=5;$D2="V2");DÜŞEYARA($H2;DATA!$A$1:$C$256;3;0);DÜŞEYARA($H2;DATA!$A$1:$C$256;2;0))

Çok teşekkürler hocam mümkünse birde butonla sadece dolu olanları otomatik olarak farklı bir yere aktarabilirmiyiz? =A1:J196 mesela bugünkü verilere göre sadece o aralık dolu.
 
Durum
Üzgünüz bu konu cevaplar için kapatılmıştır...
Üst Alt